Des de El Capitan instalar Compass ha dejado de ser “sencillo”. Lo digo entre comillas ya que Compass no ha actualizado su documentación con los nuevos requerimientos después de actualizar el OS de mac. Aquí os dejo mi proceso que me ha funcionado.

  1. Abrimos terminal.

  2. Debemos tener instalado el Xcode. No me queda claro si es necesario, pero es gratis y muy sencillo de instalar.

  3. Instalamos Xcode CTL (Command Line Tools) con este comando:

    $ xcode-select --install
  4. Instalamos brew ejecutando estos comandos:

    $ gcc --version
     
    $ ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
     
    $ brew doctor
     
    $ brew update
  5. Ahora podemos instalar Compass con los comandos siguientes:

    $ brew install ruby
     
    $ sudo gem update --system
     
    $ sudo gem install compass

En mi caso particular me ha funcionado este procedimiento pero puede que no funcione para todos los mac os futuros. ¡Dejad vuestras experiencias y opiniones en los comentarios! ¡Muchas gracias!

Categorías: Compass
Si necesitas una url corta puede usar: codygo.es/2059

2 comentarios

  1. J dice:

    Hola!

    Acabo de descubrirte porque estoy instalando compass para empezar bien el año! Mis objetivos, de hecho, para 2017 son utilizar de un modo regular SCSS, CLI (de los que ya conozco la teoría) y aprender Angular 2 (Ionic 2?)

    En fin, te cuento todo esto porque estoy siguiendo tus pasos para instalar compass y me da este error:

    Error: Running Homebrew as root is extremely dangerous and no longer supported.
    As Homebrew does not drop privileges on installation you would be giving all
    build scripts full access to your system.

    No ha pasado nada, porque le he quitado el sudo y lo he instalado igual, pero, bueno… que lo sepas!

    Un saludo y me punto a tu lista, que veo que eres alguien de quien puedo aprender jeje

    Feliz 2017!

Deja un comentario